Jump to content
Niteshade_Rune

PC is completely good for launch(new hardware installed)

Recommended Posts

I was running a solid gpu before hand, even scored High on the exploration benchmark at around 4757

 

My new 7970 GHz arrived today, while i cant really judge the true performance difference based off the benchmark and that it moved the score up to 6348 - Very High,

I'm even more excited for ARR now, cant wait to step into that gorgeous world again.

 

THis has just been a random post due to the joy of a new toy and further excitement for the game launch drawing closer slowly. :moogle:

Share this post


Link to post

That's awesome, nothing like new hardware!  I'd love to eventually build a new rig, but my ASUS G50VT laptop is doing ok in the meantime.

Share this post


Link to post

Be sure and take some screenshots in phase 4 to capture all that gloriously glory! :P

 

In phase 4? pff u kidding, I'll be taking screen shots from Phase 4 well on into and past launch lol. I am sad i may have lost my 1.0 screenshots, had a few decent views. But U can bet I'll be taking fresh ones to commemorate my return AND the new gpu lol

Share this post


Link to post

I still need to run the benchmark, but I run pretty seamlessly on my gtx660 xD

 

my cousin scored highly whilst running EvE, and WoW in the background.

 

(I wants his build)

Share this post


Link to post

Huzzah, i guess they've optimized the client and benchmark software quite a bit. I just ran the new basic benchmark included in the character creation stuff and just hit maximum for settings and my score blew my old one away lol

Share this post


Link to post

Running the benchmark on my desktop caused it to crash every time. After a little investigation and downloading some monitoring software I found my CPU was idling at 80 degrees Celsius on the Windows desktop with no programs running.

 

So yay!! New hardware for me too. (It's not as exciting when it's a heatsink and fans though.)

Share this post


Link to post

Running the benchmark on my desktop caused it to crash every time. After a little investigation and downloading some monitoring software I found my CPU was idling at 80 degrees Celsius on the Windows desktop with no programs running.

 

So yay!! New hardware for me too. (It's not as exciting when it's a heatsink and fans though.)

 

But its exciting in that it means ull get to play the gorgeous FFXIV ^_^

Share this post


Link to post

My old rig Green Goblin was able to handle the Benchmark pretty easily, though nothing spectacular. He chugged a bit on 'High Desktop' settings, though. I never really tried Maximum.

Then, I decided to just bite the bullet. I scraped together some money, and had a more suitable machine constructed for me. Then we set it up and ran the benchmark again, at max settings, and well...

 

Benchmarkscore.jpg

 

We've decided to name this rig "Beast" ^^

Share this post


Link to post

My old rig Green Goblin was able to handle the Benchmark pretty easily, though nothing spectacular. He chugged a bit on 'High Desktop' settings, though. I never really tried Maximum.

Then, I decided to just bite the bullet. I scraped together some money, and had a more suitable machine constructed for me. Then we set it up and ran the benchmark again, at max settings, and well...

 

Benchmarkscore.jpg

 

We've decided to name this rig "Beast" ^^

 

..Did you happen to forget to un-minimize the client? xDD

Share this post


Link to post

Yeah, I have a new GPU coming this monday and I can't wait to get it in and see how it handles the benchmark.

Share this post


Link to post

Welcome to the 7970 club! I present you the honorary dance of our people as we adopt you as a full member of our society. Enjoy gaming on Maximum now!

:cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar:

 

:cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar::cactuar:

Share this post


Link to post

My old rig Green Goblin was able to handle the Benchmark pretty easily, though nothing spectacular. He chugged a bit on 'High Desktop' settings, though. I never really tried Maximum.

Then, I decided to just bite the bullet. I scraped together some money, and had a more suitable machine constructed for me. Then we set it up and ran the benchmark again, at max settings, and well...

 

Benchmarkscore.jpg

 

We've decided to name this rig "Beast" ^^

 

..Did you happen to forget to un-minimize the client? xDD

 

If you mean my screen size, no... I just have a really pathetic monitor. It's the next purchase on the list.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...