Jump to content
Patch 4.4 Spoiler Policy Read more... ×
Nero

[27 October 2018] Regarding Missing Images and Attachments

Recommended Posts

So, as you probably noticed, images are a bit borked right now. As in there are none any more. And the gallery is empty.

 

It's with regret that I inform you that during some file cleaning and data migration, some kind of catastrophic error occurred that pretty much wiped the entire "upload" folder from the RPC's database. In short, a configuration error made it so IPS would try to copy a file, fail, and delete the file after failing to copy instead of retaining it.

 

This means anything that any static content that required direct uploading to the website--gallery images, post attachments, and profile avatars, among other things--are more or less gone. In terms of interface, this'll mean a lot of general visual wonkiness (since images are missing) and possibly broken post formatting if your post heavily relied on images. 

 

However, all wiki content (including images,) forum text content, hyperlinks (such as images hosted on imgur), and the actual posts and all important user data has been preserved, and many additional measures have been taken to further protect data, prevent systemic deletions, and in the event of deletions, make rollbacks easier.

 

Again, my sincere apologies for the loss of data. This won't happen again.

 

 

Share this post


Link to post

I'd like to formally apologize regarding the loss of data. This is and was my fault while trying to migrate our content from the main server's disk over to some cloud storage. What I thought was going to be a nice copy file and relink process turned out to be a rather destructive "copy the file then delete the source." In a horrible turn of events, file versioning was not turned on and I could not manually restore the images. 

 

A few of you may be wondering if undelete/file restore utilities could be used in this situation. Unfortunately, due to the nature of how they're recovered, we can't rebuild file name and paths into the exact setup they were in. While I could collect a folder of thousands of orphaned files, there would be no way of putting them back together in the right places. ><

Share this post


Link to post

I've reimported the gallery from our last known backup (before the IPS conversion). Gallery images from our old MyBB site have been restored, which brings us up to ~February 2018 content. I've also cleared the gallery of broken images, although galleries inside of clubs have not been touched. (Users are encouraged to remove them or to report them and a site staff can help clean them up for you.)

 

If you notice an asset on the site is not loading, such as theme images, editor buttons, etc, please let me know. I -think- our themes survived the worst of it, but I'm still working on repairing any assets I can on the site. (On a side note, I think I've found the cause of the pesky editor failure, but I'm still investigating how to resolve it).

Share this post


Link to post

For Club owners/moderators, I've enabled the internal content delete function. (Use with caution!) This feature will be left on unless we start receiving reports of mishandling.

 

This should allow you to remove any broken image gallery albums/pictures. Alternatively, you can also report the albums if you'd prefer a staff member handle it. 

Share this post


Link to post

We've started going through each of the forums' first pages to grab any users seen with a broken image for their profile image and/or cover image. These are being reset back to the default colored box and letter to prevent a broken image placeholder instead!

 

It's completely possible you may not have noticed this in certain forums if your browser had cached the images. (We ask browsers to cache things up to a few weeks when possible!) It's also possible that your images were re-reset while we have been making these changes. 

 

Again, I'd like to apologize for the image mess this has caused and will continue working to get everything looking nice again. If you notice a broken image anywhere, please send those my way and I will do what I can to get it sorted out!

Share this post


Link to post

Forums should mostly look cleaned up now! I've also gone through all active clubs and their members, regenerating default profile pictures for anything broken. If you noticed your icon was suddenly gone, this is why! Your browser likely had it cached (good browser! Give it a gentle pat and compliment for working well), but to anyone else, it was probably a broken link. 

 

It should be safe to reupload things (or has been since right after the incident), but if you'd like a part of the site checked out, please let me know! I'm still working on cross-referencing things between a few machines to rule out any one computer/browser, but I want to say we're mostly up and running as we should be. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×